Informational Update: Chromium Update Impacting Browser Extensions

Incident Report for Uniqkey

Resolved

Chromium support reports that the issue should be resolved in version 137.0.7151.103.
Posted Jun 17, 2025 - 10:13 CEST

Monitoring

A recent Chromium update has caused widespread issues with browser extensions, including UniqKey, across multiple platforms.
This is not specific to UniqKey but affects all Chromium-based extensions.

We're keeping a close eye on the situation, and waiting for further information from Google.

A support ticket on the Google Chrome support forum has been created here for anyone curious about the development: https://support.google.com/chrome/thread/346094912?hl=en&msgid=346177504

For now, using a browser like Firefox should work without issues.
If Firefox is not installed on your PC, you can download it here: https://www.mozilla.org/en-US/firefox/windows/
The Uniqkey extension for Firefox can be downloaded here: https://addons.mozilla.org/en-US/firefox/addon/uniqkey-2-0/
Posted Jun 04, 2025 - 10:04 CEST
This incident affected: Frontend (Browser Extension App).